Commit 83bee15a authored by Gerson SUNYE's avatar Gerson SUNYE
Browse files

Update dependencies and correct codegen script

parent e451f8f6
...@@ -8,34 +8,22 @@ ...@@ -8,34 +8,22 @@
"test": "ng test", "test": "ng test",
"lint": "ng lint", "lint": "ng lint",
"e2e": "ng e2e", "e2e": "ng e2e",
"codegen": "./node_modules/.bin/thrift-typescript --sourceDir ../not-alone-core/src/main/thrift/ --outDir ./target/generated-sources/thrift/" "codegen": "\"./node_modules/.bin/thrift-typescript\" --sourceDir \"../not-alone-core/src/main/thrift/\" --outDir \"./src/codegen/\""
}, },
"private": true, "private": true,
"dependencies": { "dependencies": {
"@angular/animations": "^10.1.3",
"@angular/common": "^10.1.3",
"@angular/compiler": "^10.1.3",
"@angular/core": "^10.1.3",
"@angular/forms": "^10.1.3",
"@angular/platform-browser": "^10.1.3",
"@angular/platform-browser-dynamic": "^10.1.3",
"@angular/router": "^10.1.3",
"@creditkarma/thrift-client": "^0.16.1", "@creditkarma/thrift-client": "^0.16.1",
"@creditkarma/thrift-server-core": "^0.16.1", "@creditkarma/thrift-server-core": "^0.16.1",
"@creditkarma/thrift-typescript": "^3.7.6", "@creditkarma/thrift-typescript": "^3.7.6",
"@ngtools/webpack": "^10.1.3", "@ngtools/webpack": "^10.1.3",
"@types/thrift": "^0.10.10", "@types/thrift": "^0.10.10",
"core-js": "^3.6.5", "core-js": "^3.6.5",
"marked": "^1.2.0",
"rxjs": "~6.6.3", "rxjs": "~6.6.3",
"thrift": "^0.13.0", "thrift": "^0.13.0",
"zone.js": "^0.11.1" "zone.js": "^0.11.1"
}, },
"devDependencies": { "devDependencies": {
"@angular-devkit/build-angular": "^0.1001.3", "@angular/cli": "^11.0.2",
"@angular/cli": "~10.1.3",
"@angular/compiler-cli": "~10.1.3",
"@angular/language-service": "^10.1.3",
"@types/jasmine": "~3.5.14", "@types/jasmine": "~3.5.14",
"@types/jasminewd2": "~2.0.8", "@types/jasminewd2": "~2.0.8",
"@types/node": "~14.11.2", "@types/node": "~14.11.2",
...@@ -48,6 +36,7 @@ ...@@ -48,6 +36,7 @@
"karma-jasmine": "~4.0.1", "karma-jasmine": "~4.0.1",
"karma-jasmine-html-reporter": "^1.5.4", "karma-jasmine-html-reporter": "^1.5.4",
"protractor": "^7.0.0", "protractor": "^7.0.0",
"shx": "^0.3.3",
"ts-node": "~9.0.0", "ts-node": "~9.0.0",
"tslint": "~5.20.1", "tslint": "~5.20.1",
"typescript": "~4.0.3" "typescript": "~4.0.3"
......
...@@ -71,5 +71,4 @@ ...@@ -71,5 +71,4 @@
</resources> </resources>
</build> </build>
</project> </project>
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment