main.product 1.82 KB
Newer Older
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
<?xml version="1.0" encoding="UTF-8"?>
<?pde version="3.5"?>

<product name="Benchmark tool" uid="fr.inria.diverse.cloning.benchmark.tool.product" id="fr.inria.diverse.cloning.benchmark.tool.BenchmarkToolSuite" application="fr.inria.diverse.cloning.benchmark.tool.application" version="0.1.0.qualifier" useFeatures="false" includeLaunchers="true">


   <configIni use="default">
   </configIni>

   <launcherArgs>
      <vmArgs>-Xms128m -Xmx2048m
-agentlib:jdwp=transport=dt_socket,server=y,suspend=n</vmArgs>
      <vmArgsMac>-XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts</vmArgsMac>
   </launcherArgs>

   <windowImages/>


   <launcher name="cloning-benchmark">
      <solaris/>
      <win useIco="false">
         <bmp/>
      </win>
   </launcher>


   <vm>
   </vm>


   <plugins>
      <plugin id="fr.inria.diverse.cloning.benchmark.tool" version="0.1.0.qualifier"/>
      <plugin id="org.eclipse.core.runtime"/>
      <!--<plugin id="org.eclipse.swt"/>
	  <plugin id="org.eclipse.swt.win32.win32.x86_64" fragment="true"/>
	  <plugin id="org.eclipse.swt.gtk.linux.x86_64" fragment="true"/>-->
	  
	  <plugin id="org.eclipse.swt"/>
      <plugin id="org.eclipse.swt.gtk.linux.x86_64" fragment="true"/>
	  <plugin id="org.eclipse.swt.gtk.linux.x86" fragment="true"/>
      <plugin id="org.eclipse.swt.win32.win32.x86" fragment="true"/>
      <plugin id="org.eclipse.swt.win32.win32.x86_64" fragment="true"/>
	  <plugin id="org.eclipse.swt.cocoa.macosx.x86_64" fragment="true"/>
	  
   </plugins>

   <configurations>
      <plugin id="org.eclipse.core.runtime" autoStart="true" startLevel="0" />
      <property name="osgi.instance.area.default" value="benchmarktool-workingdir" />
	  
	    <plugin id="org.eclipse.swt" autoStart="true" startLevel="0" />
   </configurations>

</product>